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Author's Note: The EIA has changed dramatically since this tutorial was written.  Ergo, the screen 

shots are somewhat out of date.  The change to the interface isn't necessarily what you would 

call "dramatic," so the current screen shots will do for now.  However, I will attempt to update 

them when I have a chance. 

I. General Information Return to the Top  

For starters, here’s the first screen that you should see when starting EIA. 



 

Figure 1.  

Items of note  

�      The Tools has two options in it. 

 The Roll Dice sub-menu gives you several options for the number of sides, and 

when you select one, a dialog box appears allowing you to enter the number of dice to 

roll.  The default number of dice to roll is 1.  

 Create/Edit Spells gives you the opportunity to create your own spells.  If you 

create your own spell, you can indicate  items such as spell duration, target, etc. so that 

information is ready for quick reference.   

�      The Options menu has four items in it: 

 Auto Delete Spells: automatically eliminates a spell from the spells’ list if the 

number of rounds left for that spell drops to 0.  If not activated, the spell remains in the list 

until manually deleted (q.v.), allowing the number of rounds to drop to negative 

numbers.  This might be useful if you might go “back in time” in the initiative order and 

didn’t want to have to remember when to cast spells again.  It receives a check mark if 

activated and no mark if not.  By default, this option is selected.  

 Massive Damage: If selected, the EIA requests whether the user wants an on-the-

fly massive damage save when damage of 50 or more hit points is dealt.  By default, this 

option is selected.  



 Stabilization: request whether characters receive on-the-fly stabilization rolls if their 

hit points are below 0. If option isn't selected, character hit points must be altered 

manually.  It receives a check mark if activated and no mark if not.  By default, this 

option is selected.  Warning: going "back in time" (i.e., to prior rounds in combat) won't 

have any affect on hit points or stabilization. Stabilization will become a manual process 

if you've done so.  

 Use DMG XP: Use Table 2-6 in the DMG for calculating XP awards on the Treasure 
and XP Generator rather than a standardized formula.  See the FAQ for more details.  By 

default, this option is not selected so that a custom calculation is performed.  

�      Many data entry boxes require only numbers.  In those cases, there are very small buttons, 

known as Up Down buttons, that with each click either raise or lower the current value in the 

associated data entry box.  If you’re just raising or lowering a number by one or two, these 

buttons are easier to use than switching over from a mouse to keyboard entry. 

�      Many of the menu options have shortcut keys associated with them.  For example, to open 

the Characters screen (q.v.), you can press the “A” on your keyboard while holding down 

the control key (usually abbreviated, “Ctrl”).  This Ctrl-A combination appears on the 

Characters menu (q.v.) to the right of the Create/Edit dB Character option (q.v.).  In most 

cases, this document doesn’t point out these shortcuts, so always examine the menu option 

you’re selecting to see if there’s an easier way to activate that feature. 

�      You can resize the screens, and if you do so, the controls on the screens (including their font 

sizes) resize as well.  However, there are maximum and minimum sizes allowed. 

II. Registration Return to the Top  

Registration is a three-step process.  First, you send a payment via PayPal to wetpaint2000@hotmail.com.  The 

current cost of the EIA is , unless you want to install it on multiple machines, in which case I'm charging a unlimited 

license fee.  Second, you click on the registration menu and select Request Registration Code (see Figure 2).  



   

Figure 2.  

This brings up a new email message from your default email program.  The subject line will be 

written for you, so don’t change it.  As for the body of the email, it will provide the following string 

to you, which you should complete: 

Name: ____  Transaction Number: ____  Email Address: ____ 

That is, I need to know your name, PayPal transaction number, and email address from which 

you sent payment.  Without these three items of information, I won’t be able to respond to your 

email with your activation code. 

Third, once you’ve received my email providing your registration code, return to the registration 
menu and select Register Product (see Figure 3).  This brings up a dialog box requesting the code 

I gave you.  Copy and paste the registration code into the text entry box and select okay.  Your 

product should be registered, and the registration menu will no longer be available. 



   

Figure 3.  

Items of note  

�      IMPORTANT: It’s highly unlikely that there should be any problems with registration, and I will 

go to great lengths to ensure that your program is registered on your computer.  However, if 

your computer is giving you problems that I can’t solve, I may be in a position of having to 

send you an “automatically registered” product in order to get yours to work.  I won’t do 

that.  Instead, I’ll refund your money.  Although (and in fact, because) it’s highly unlikely that 

such a problem could occur, it would be too great a risk to the protection of the EIA to allow 

automatically registered copies to circulate.  If I can’t provide you a solution from afar, and if 

Delaware is too far a commute to give me access to your computer to verify the problem 

actually exists, then simply request your money back.  This offer of a refund is good for 30 

days from the purchase of your license. 

�      REMINDER: Your registration code works on only one hard drive: the one for which you 

registered the product.  If you try to register your product on a second hard drive using the 

original hard drive’s registration code, it won’t work.  Your computer won’t explode, but it 

won’t work.  If you purchase a new hard drive, you’ll need a new license for that hard drive.  

Because I can’t undo the registration code once you receive it, I won’t allow an exchange 

of codes.  These policies are in place to minimize the chance of pirating and fraud.  

Considering the relatively low cost of the EIA, I find these to be reasonable policies. 

�      NEW VERSIONS: New versions will require new registration codes, but if you qualify for a free 

upgrade for some reason, you’ll get the new registration code automatically. 



�      As you might expect, you won't be able to use many of the features of the EIA if the 

application isn't registered. 

III. Setting up Combat Return to the Top  

When you first open the EIA, you are brought to the Combat screen (see Figure 1, above).  This is the workhorse of 

the EIA.  The key features on this screen are the characters’ list, the “Enter Combat” button, the “Roll Initiative” 

button, the “Assign Initiative” button, and the initiative data entry box.  You also have several menu options, some 

of which duplicate the features of the buttons. 

Step 1: Load characters into the characters’ list Return to the Top  

Your first step is to load characters into the list box.  This is accomplished in one of three ways.  
You may open an XML file containing character data (see Figure 4), you may open a character 

that you’ve created using the Character screen (see Figure 5), or you may open a combat file 

(q.v.) containing references to several of these characters (see Figure 6).  Note on Figure 5: the 

parenthetical, “(custom),” doesn’t appear next to all custom characters.  I’ve actually included 

that in the names of those characters for the purposes of pointing them out as custom 

characters. 

 

Figure 4.  



   

Figure 5.  

   



Figure 6.  

After Step 1 is complete, the Combat screen should look something like Figure 7. 

   

Figure 7.  

Step 2: Assign Identifiers Return to the Top  

What if you have more than one dark elf on the board, each with the same statistics?  How do 

you tell them apart?  That’s where the identifier comes into play.  Select a character from the 

characters’ list, and then go to the Characters menu and select Modify Identifier.  This will bring 

up a dialog box into which you’ll enter the modifier.  This is free form text, so you can enter 

anything you want.  A set of identifiers can be as simply as #1, #2, etc., or A, B, etc.  You may 

prefer to use different minis for similar creatures, so you could use the name of the mini 
representing the character.  That’s how it appears below in Figure 8. 



 

Figure 8.  

Step 3: Roll Initiative for the Group Return to the Top  

This is the easy part.  Simply click on the Roll Initiative button, and all characters will have a 

separate initiative roll generated, modified by their individual initiative modifiers.  When the 

initiative scores are changed, the characters’ list will reorder itself by each character’s score and 

modifier (in that order of priority). 

Step 4: Assign Specific Initiatives Return to the Top  

A GM may decide that he wants an NPC to go in a particular order no matter how the dice roll.  

A GM may decide that he wants all NPCs to have the same initiative score.  A typical player 

prefers to roll his own dice.  To deal with all of these situations, the GM can assign initiative scores 

to the players using the Assign Initiative button and data entry box.  Simply make sure the 

correct character is highlighted in the characters’ list, enter the initiative score you’d like in the 

data entry box, and then click on the Assign Initiative button. 

Once all four steps are completed, the Combat screen should look something like Figure 9.  In this 

case, I’d say the odds are against the PCs.  ☺ 



   

Figure 9.  

Items of note  

�      You can save your current combat configuration as a combat (*.cbt) file.  Select Save from 

the File menu and choose a file name.  All that is saved is a reference to the characters; hit 

point damage, identifiers, etc. are not saved. 

�      You can close a combat file without saving it.  Select Close from the File menu.  No error 

message is given if you haven’t saved changes to the current combat file. 

�      You can open multiple combat files at the same time. 

�      You can access the File menu by right-clicking anywhere on the grid appearing on the 

Combat screen.  

�      You can access the Character menu by right-clicking anywhere on the characters’ list. 

�      You can change the column widths of the characters’ list, even revealing hidden columns 

whose width is currently set to zero.  If you want to return to the default widths, simply choose 

Reset Columns from the File menu. 

�      A scroll bar will appear on the right side of the characters’ list if more characters are inserted 

than can fit in the visible area of the list. 



�      As of right now, the only third-party XML format supported by the EIA is E-Tools*, but future 

versions will support other formats. 

IV. Starting Combat Return to the Top  

By clicking on the Enter Combat button, not surprisingly, you enter combat.  The same button then gives you the 

ability to leave combat.  When in combat, the Combat screen changes as shown in Figure 10. 

   

Figure 10.  

Once Combat has started, the characters’ list no longer reorders characters by initiative scores, 

so initiative order must be changed manually (q.v.).  You may no longer manually select a 

character, but rather you must wait until its turn in order to allow it to act, at which point it 

becomes the “current character.”  The controls governing combat appear down the right side 

of the Combat screen.  Also, various menus are made visible or invisible, and the spells’ list is now 

visible beneath the characters’ list. 

Scrolling Through the Rounds Return to the Top  

The first important set of controls is the Round button set.  By clicking to the right, you go forward 

in initiative order, and by clicking to the left, you go backwards.  You can never go before the 

1st round, so surprise rounds are (currently) handled manually.  As you go backwards, the 

number of rounds left for a given spell (q.v.) will increase, but never higher than their initial rounds 

left value.  So, if you go too far back, you may cause problems with your spells.  We’ll learn how 

to address this problem later.  As for hit points, going backwards won’t restore lost hit points.  That 

is, the EIA doesn’t (currently) track when a character lost hit points and how much, but rather 



what your current total hit points are.  Going backwards won’t undo what you’ve reported to 

the EIA. 

Selecting a Target Return to the Top  

Because once combat has started you no longer have the ability to select a character outside 

the current initiative order, you must use the Target set of controls to record damage to a 

character.  The first step is to use the drop down target list to select a character.  This control 

appears below the word, “Target,” and it contains a list of every character appearing in the 

characters’ list.  Once you select a “target character,” you can use one of the buttons below 

the drop down target list to either view the character’s statistics block (“stat block”) or roll a 

saving throw.  Each of these buttons has a word on it that indicates its function.  

Viewing a Target Character’s Stat Block Return to the Top  

If you chose to view the stat block of a character, you’d see something like what appears in 
Figure 11.  

 

Figure 11.  

Figure 12 shows you something a little bit different.  In this case, you chose a character whose stat 

block is too big for the screen.  Accordingly, a scroll bar appears to the right, allowing you to go 
up and down to view the entire stat block.  Figure 12 also shows the content of the only menu 

appearing with the stat block.  The File menu has one option, Close.  The Close option simply 

returns you to where you were before you brought up the stat block. 



 

Figure 12.  

Rolling a Saving Throw for the Target Character Return to the Top  

Figure 13 shows a sample saving throw rolled for the current character, which can be done only 

by referencing the Current sub-menu of the Rolls menu, visible only when within combat.  Saving 

throws can also be rolled for the Target character, which can be accomplished either by 

clicking on one of the command buttons beneath the drop down target list or by referencing 

the Target sub-menu of the Rolls menu.  Of course, the correct character must be selected in 

the drop down target list in order to get the right save.  If there are situational modifiers to add to 

the roll (e.g., circumstance bonuses), you’ll have to do that mentally.  The rolls consider only the 

modifiers provided by either the XML file or the character’s database record (for characters 

created within the EIA). 



   

Figure 13.  

Selecting a Spell to Cast Return to the Top  

As you’re scrolling through the characters, you may notice that the drop down list underneath 

the words, “Spells Available,” alternates from having entries to not having entries.  This is the drop 

down spells’ list, and it contains the spells with non-instantaneous duration that are available 

known to the current character, as illustrated in Figure 14 below.  Because some characters 

aren’t casters, the box is sometimes empty. 

The drop down spells’ list contains the name of the spell and its formula for calculating its 
duration.  This is illustrated in Figure 14 below.  Because this combination of information is usually 

too long to appear in the list, the currently selected spell’s duration is assigned to what’s called 

the Tool Tip Text of the drop down list.  Therefore, when you select a spell in the list, you can 

leave your mouse pointer motionless over the drop down list, and the duration will pop-up in a 

small label.  



   

Figure 14.  

Having the duration information helps you calculate how many rounds to enter in the Rounds 

data entry box that appears below the drop down spells’ list.  Once you’ve calculated and 

entered the number of rounds, click the button labeled Cast Spell, and the spell will appear in 

the spells’ list, along with the number of rounds left in the spell and the name and identifier of the 

character that cast it.  A populated spells’ list is illustrated in Figure 15.  Note: if you modify the 

identifier of the caster after the spell is cast, it won’t (currently) be transferred to the spells’ list. 



   

Figure 15.  

Changing the Number of Rounds Left Return to the Top  

For a wide variety of reasons, you may want to modify the number of rounds left in a spells 

duration.  To do that, you simply access the Spell menu, which gives you three options: Increase 

Rounds, Decrease Rounds, and Remove.  Each has a shortcut key combination associated with 

it, Ctrl+I, Ctrl+M, and Ctrl+N respectively.  Memorizing those shortcuts is quite useful.  Please note 

that these functions are applied to the spell that’s currently selected in the spells’ list. 

Items of note  

�      You can access the Spell menu by right-clicking anywhere on the spells’ list.  

�      You can change the column widths of the spells’ list, even revealing hidden columns whose 

width is currently set to zero.  If you want to return to the default widths, simply choose Reset 

Columns from the File menu. 

�      A scroll bar will appear on the right side of the spells’ list if more spells are inserted than can 

fit in the visible area of the list. 

�      Because some class spell lists are huge (e.g., the standard divine caster), you’ll sometimes 

experience a slight pause while the drop down spells’ list is populated.  On my PCs, the 

pause isn’t even one second long, but in any case it won’t be a dramatically long wait. 



�      While in combat, you can add characters or entire combat files to the current combat, but 

they’ll be assigned the default initiative roll of 0.  You’ll have to roll each new character’s 

initiative (using the target combo box and the Rolls menu), and then use the delay/ready 

action to move them where you want them in initiative order. 

�      The stat block is available even when you’re outside of combat.  In this case, you have the 

additional option of bringing up the stat block of a character by double-clicking on that 

character in the characters’ list.  You can also do that from within combat, but because the 

character currently in initiative order is always selected, it always brings up that stat block. 

�      As with characters, you can pull up a stat block for a spell by double-clicking on the spell 

that appears in the spell list.  If you have typed in a spell that doesn't appear in the drop 

down spells’ list, the stat block will be empty.   You can add a spell to the drop down spells’ 

list by using the Create/Edit Spells option under the Tools menu.  

V. Creating and Editing Characters Return to the Top  

Disclaimer: We know we’re running this into the ground, but once again, the EIA is not a robust 

character generation tool.  It won’t perform any error checking.  For example, the custom 

character used in the screen shots is a 2nd level fighter that casts spells and manifests psionic 

powers.  You should create your character using whatever tools you normally use (s/w, paper, 

pencil, whatever), and then enter it into the character database.  Garbage in, garbage out. 

Bringing up the Character Screen Return to the Top  

The Character screen can be brought up by access the Create/Edit dB Character option under 

the Characters menu of the Combat screen (available both in and out of combat).  You can 

also use the Ctrl-A keyboard combination.  Characters are presented alphabetically, and by 

default, the first character in the database will appear, along with the character’s basic stats, as 
illustrated in Figure 16 below. 

   

Figure 16.  



Using the four buttons at the top of the Character screen, you can view the character’s basic 
stats (Figure 16, above), attacks (Figure 17), spells known (Figure 18), or languages and 

miscellaneous notes (Figure 19). 

   

Figure 17.  

 

Figure 18.  



   

Figure 19.  

Viewing Other Characters Return to the Top  

To view other characters, you use the buttons and drop down list along the bottom of Character 

screen.  Let’s call the character that’s currently being viewed the “current character.”  The first 

button jumps to the first character in the database, the second button moves to the character 

immediately before the current character, the third button moves to the character immediately 

after the current character, and the fourth button jumps to the last character in the database.  

Remember, the characters are ordered alphabetically, so first, second, last, etc. relate to the 

alphabetical listing, which will almost certainly not be the order in which you entered them.  

Consider that when deciding how to name characters.  For example, you may choose to enter 

names in the format, ‘last name, first name.’ 

As your list of custom characters grows, you may find the buttons too fine a tool to browse 

properly.  The drop down character list gives you another means of finding the right character.  

Click on the drop down character list control, and you’ll see a list (with a scroll bar, if needed) of 

all your characters.  Select the one you want to view/edit, and the database will jump to that 
character.  See Figure 20. 



 

Figure 20.  

Adding New Characters Return to the Top  

To the right of the drop down character list, you’ll see three more buttons.  If you click the first 

button (Add New), you’ll enter “add mode,” and you’ll be adding a new character.  Clicking 

that same button (which should now say Cancel) will cancel the character adding process.  On 

the other hand, clicking the next button over (Save) will save the current record.  Save works this 

way whether you’re adding a new character or you’ve edited an existing character. 

Closing the Character Screen Return to the Top  

Obviously, the button at the bottom right corner of the Character screen (Close) closes out the 

Character screen and returns you to the Combat screen.  This function can also be accessed 

via the File menu. 

VI. Conclusion Return to the Top  

We hope you found this tutorial useful.  If you have any questions or comments, please email us 
at wetpaint2000@hotmail.com.  The FAQ that follows will grow as we receive your input. 

 


